Check injection light on dash board

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

Cilgrug
Posts: 3
Joined: Fri Nov 10, 2017 7:39 am
Currently Drives:: Renault megane 08 1.5 dci tech line
Renault megane 03 1.5 dci

Check injection light on dash board

Postby Cilgrug » Sat Nov 11, 2017 6:45 am

My 03 plate megane 1.5 dci has a check injection light on dash board it won’t start unless you pull the fuel pipe off at the pump and manually pump it till there is no air in the fuel pipe then connect the pipe up and it will start and run it has a new fuel filter in it and a replacement injector as they were all tested and one was faulty I would like to get it running again any one have any ideas on what’s causing the problem

triumph2.5man
Advanced Driver
Posts: 288
Joined: Fri Jan 29, 2010 8:52 pm
Currently Drives:: Mondeo TDCI mk3 2002
Pug 307HDI90 1.6 (family car)
Megane II dynamique 1.5dci 722 engine 2003
Ford Galaxy 115bhp 2002 (family car)
Megane 3 1.5dci 2009 832 engine (family car)

Re: Check injection light on dash board

Postby triumph2.5man » Sun Nov 12, 2017 6:43 pm

How many miles has your 03 done? Mine got to 100k when it began to play up. I discovered that the rollers in the Delphi fuel pump were worn almost flat on both sides resulting in low fuel rail pressure and swarf was blocking the injectors. It is problems like this that result in so many Meganes ending up in scrappies. I was able to fix the problem quite cheaply. I have written about it on here previously. Mine runs very sweetly and does so only because I maintain it myself - I regard it as a challenge!! I do use CLIP though. Cheap and nasty code readers would not work with this car, probably because it is pre OBD2. I have written this before too!!
Mike

ABliss
Passed Theory
Posts: 32
Joined: Thu Mar 30, 2017 8:53 pm
Currently Drives:: 2004 Megane MKII 1.5DCi (80)

Re: Check injection light on dash board

Postby ABliss » Tue Nov 14, 2017 9:44 pm

Cilgrug wrote:My 03 plate megane 1.5 dci has a check injection light on dash board it won’t start unless you pull the fuel pipe off at the pump and manually pump it till there is no air in the fuel pipe then connect the pipe up and it will start and run it has a new fuel filter in it and a replacement injector as they were all tested and one was faulty I would like to get it running again any one have any ideas on what’s causing the problem



I had the exact same issue one day. Unfortunately I didn't get to the bottom of it. All I did to get it started again was to pump the primer bulb a couple of times and voila! She would come back to life. I only had this problem twice, and never repeated itself.


Return to “Problems / Questions”

Who is online

Users browsing this forum: Bing [Bot] and 20 guests